Sıradaki içerik:

Intel, Windows, Linux Güvenlik Açıklarını Düzeltti

e
sv

Buggy WordPress Eklentisi Güvenlik Açığı Çıktı

48 okunma — 12 Şubat 2021 00:33
avatar

admin

  • e 0

    Mutlu

  • e 0

    Eğlenmiş

  • e 0

    Şaşırmış

  • e 0

    Kızgın

  • e 0

    Üzgün

Responsive Menu

Responsive Menu WordPress eklentisindeki kritik ve yüksek önem dereceli güvenlik açıkları, Wordfence tarafından keşfedildiği üzere 100.000’den fazla siteyi hack saldırılarına maruz bıraktı.

Responsive Menu , yöneticilerin W3C uyumlu ve mobil kullanıma hazır sorumlu site menüleri oluşturmasına yardımcı olmak için tasarlanmış bir WordPress eklentisidir.

Wordfence ekibi üç güvenlik açığı buldu !

Wordfence ekibi, temel kullanıcı izinlerine sahip saldırganlar tarafından rastgele dosya yükleme ve uzaktan rastgele kod çalıştırma yetkisine sahip üç güvenlik açığı buldu.

İlk kusur, kimliği doğrulanmış saldırganların, sonunda uzaktan kod yürütme gerçekleştirmelerine olanak tanıyan rastgele dosyalar yüklemelerine olanak tanır.

Diğer iki güvenlik açığı, potansiyel bir tehdit aktörünün, eklentinin eklenti ayarlarını değiştirme taleplerini gerçekleştirmesine olanak tanır ve bu da, uzaktan kod yürütülmesine izin veren rastgele dosyalar yüklemelerine izin verir.

Kritik güvenlik açığını kötüye kullanmak için, abone olarak veya başka bir düşük seviyeli kullanıcı olarak oturum açan saldırganlar, ZIP dosyaları olarak arşivlenmiş ve kötü niyetli PHP dosyaları içeren menü temalarını yüklemelidir.

Arşiv yükleme için çıkarıldıktan sonra, saldırgan, kötü amaçlı kodu uzaktan yürütmek için dosyalara site ön ucu aracılığıyla erişebilir ve bu da sonuçta tam bir sitenin ele geçirilmesine yol açabilir.

Responsive Menu

Responsive Menu’nün arkasındaki şirket olan ExpressTech, 17 Aralık ve 4 Ocak arasındaki çoklu temas girişimlerinin ardından 19 Ocak 2021’de güvenlik sorunlarını düzeltti.

Rapor soruları, Wordfence’ın WordPress Eklentiler ekibine iletilmesinin ardından 10 Ocak’ta yanıtlandı.

Güvenlik sorunları Responsive Menu 4.0.0 ila 4.0.3 sürümlerini (veya eski modda çalışan) etkilediğinden, kullanıcıların kötüye kullanma girişimlerini önlemek için hataları gideren 4.0.4 sürümüne hemen güncelleme yapmaları önerilir.

Wordfence, “Bu üç güvenlik açığının tümü, arka kapılar, spam enjeksiyonları, kötü amaçlı yönlendirmeler ve diğer kötü niyetli faaliyetler gibi sonuçlara yol açabilecek bir sitenin ele geçirilmesine yol açabilir,” diye ekledi .

Yaklaşık 50.000 site hâlâ saldırılara maruz kalıyor

Düzeltilmiş sürüm olan Responsive Menu 4.0.4 19 Ocak’ta piyasaya sürülmüş olsa da, WordPress eklentisinin deposunda bulunan istatistiklere göre düne kadar 50.000’den fazla yeni indirme kaydedildi.

Bu rakamlar hem güncellemeleri hem de yeni yüklemeleri içerdiğinden, Responsive Menu kullanan neredeyse 50.000 WordPress sitesi saldırganlar tarafından hala ele geçirilebilir.

Wordfence, bu haftanın başlarında , NextGen Gallery eklentisinde , bilgisayar korsanlarının arka kapılar enjekte etmesine , hileli yöneticiler oluşturmasına ve potansiyel olarak hala yamalanmamış eklenti sürümleri çalıştıran 530.000’den fazla WordPress sitesini ele geçirmesine izin veren iki kritik ve yüksek önem derecesine sahip CSRF güvenlik açığı bildirdi .

WordPress, geliştiriciler tarafından piyasaya sürüldükten sonra, tehdit aktörlerinin saldırılarında eski WordPress eklentilerindeki zaten sabit güvenlik açıklarından sık sık yararlandıklarını gördükten sonra eklenti güvenlik güncellemelerini mümkün olan en kısa sürede yüklemelidir.

  • Site İçi Yorumlar

En az 10 karakter gerekli